CentOS8编译安装(升级)php7.4.7 的问题解决方法

CentOS8编译安装(升级)php7.4.7 的问题解决方法

系统升级到CentOS8后,重新编译安装 最新的PHP7.4.7版本时遇到了一些问题,今天就总结下来分享给大家。

PHP7源代码的编译功能选项配置:

./configure --prefix=/apps/php7/ --with-apxs2=/apps/httpd/bin/apxs  --enable-mbstring --with-mysqli --with-pdo-mysql --with-zlib

编译过程中报错信息:

configure: error: Package requirements (oniguruma) were not met: Package 'oniguruma', required by 'virtual:world', not found

解决方法: 通过源码包安装方式

wget https://github.com/kkos/oniguruma/archive/v6.9.4.tar.gz -O ./oniguruma-6.9.4.tar.gz
tar zxf ./oniguruma-6.9.4.tar.gz
cd oniguruma-6.9.4
./autogen.sh
./configure --prefix=/usr
make && make install
转载本文时请注明出处及本文链接地址CentOS8编译安装(升级)php7.4.7 的问题解决方法

发表评论

您的电子邮箱地址不会被公开。 必填项已用*标注